apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Stein <gst...@lyra.org>
Subject can we require libtool 1.4 ?
Date Tue, 14 May 2002 07:44:33 GMT
libtool 1.3 has problems with intra-library dependencies. This is making
some of the dependency stuff in apr(-util) a bit more complicated than it
needs to be.

The simple answer is to require libtool 1.4.

Subversion has been on libtool 1.4 since last October. After some initial
grumbling, there hasn't been *any* problem with people complaining about not
having libtool 1.4 available.

I think it would simplify our life, and give us proper dependencies, yet not
cause any undue burden (libtool 1.4 has been out for a long while now...)

>From IRC, I already have a +1 from Justin and Sander. So I'd say we have
enough positive traction for the move. But does anybody see any *problems*
or have a reason to *not* require 1.4 ?

Cheers,
-g

-- 
Greg Stein, http://www.lyra.org/

Mime
View raw message