apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philip Martin <phi...@codematters.co.uk>
Subject apr-util, autoconf-2.53 and builddir != srcdir
Date Tue, 09 Apr 2002 10:53:51 GMT
Hi

Subversion's ac-helpers/aprutil.m4 has the code

    ac_configure_args_save=$ac_configure_args
    ac_configure_args="$ac_configure_args MKDIR=\"$MKDIR\""
    SVN_SUBDIR_CONFIG(apr-util, --with-apr=../apr)
    ac_configure_args=$ac_configure_args_save

This causes MKDIR to be set for the apr-util configure, which is
required for the xml/expat directory to be created by configure when
builddir != srcdir.

At least that's how it used to work. It doesn't work for me now, and
I think it is because I have just switched to autoconf-2.53 (which has
just appeared in debian/testing). The error message is

configuring package in xml/expat now
/home/pm/sw/subversion/svn/apr-util/configure: xml/expat: No such file or directory
/home/pm/sw/subversion/svn/apr-util/configure: cd: xml/expat: No such file or directory
configure: warning: MKDIR=/home/pm/sw/subversion/svn/ac-helpers/install-sh -c -d: invalid
host type
loading cache /dev/null
checking host system type... config.sub: too many arguments
Try `config.sub --help' for more information.

Now ac_configure_args contains the arguments passed to the configure
process, and sure enough I get the same error message by invoking the
command

$ ../../svn/apr-util/configure MKDIR='/home/pm/sw/subversion/svn/ac-helpers/install-sh -c
-d'


This form of the command works

$ MKDIR='/home/pm/sw/subversion/svn/ac-helpers/install-sh -c -d' ../../svn/apr-util/configure

as does exporting MKDIR.


Is this an apr-util problem, a Subversion problem or is autoconf-2.53
broken?

-- 
Philip, who is fed up with shell scripts.

Mime
View raw message