apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Erenkrantz <jerenkra...@apache.org>
Subject Re: libtool fails version check in expat
Date Sat, 27 Apr 2002 05:47:45 GMT
On Fri, Apr 26, 2002 at 10:30:03PM -0700, Roy T. Fielding wrote:
> Making all in expat
> /bin/sh ../libtool --mode=compile cc -DHAVE_CONFIG_H -DPACKAGE='"expat"' 
> -DVERSION='"expat_1.95.2"' -I/Users/fielding/ws/httpd-2.0/srclib/apr-util/
> xml/expat/lib -I.. -I/Users/fielding/ws/httpd-2.0/srclib/apr-
> util/xml/expat/lib  -g -O2 -c xmlparse.c
> libtool: ltconfig version `' does not match ltmain.sh version `1.3.5'
> Fatal configuration error.  See the libtool docs for more information.
> make[5]: *** [xmlparse.lo] Error 1
> 
> This is Darwing while using Pier's auto*/libtool stuff.

ltmain.sh is not in the repository for expat - this comes from
(g)libtoolize when running apr-util/xml/expat/buildconf.sh.

I bet you ran buildconf with 1.3.5, tried to build APR, it failed,
you installed Pier's stuff to get 1.4+, reran buildconf and then
ran into this.

The following line in apr's buildconf looks like its corrollary
is needed for expat:

# Remove any libtool files so one can switch between libtool 1.3
# and libtool 1.4 by simply rerunning the buildconf script.
(cd build ; rm -f ltconfig ltmain.sh libtool.m4)

How close am I?  -- justin

Mime
View raw message