apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thom May <t...@planetarytramp.net>
Subject VPATH builds
Date Sun, 14 Apr 2002 15:11:02 GMT
Is there some hidden magic to getting apr-util to configure and build with
builddir!=srcdir?
I'm currently running: ~/httpd-2.0/configure --srcdir=~/httpd-2.0
--with-apr=~/httpd-2.0/srclib/apr

and the apr-util build dies whilst trying to locate apr:
Configuring Apache Portable Runtime Utility library...

configuring package in srclib/apr-util now
/home/thom/httpd-2.0/configure: srclib/apr-util: No such file or directory
/home/thom/httpd-2.0/configure: cd: srclib/apr-util: No such file or
directory
loading cache /dev/null
checking for APR... configure: error: the --with-apr parameter is incorrect.
It must specify an install prefix, a
build directory, or an apr-config file.
configure failed for srclib/apr-util

I have also tried specifying the apr-config file that gets generated in the
build dir, with the same result.
Help?! :)
-Thom
-- 
Thom May -> thom@planetarytramp.net

Pacey: Sisters are offlimits. Like mothers. But pretty.

Mime
View raw message