apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Max Okumoto <okum...@ucsd.edu>
Subject solaris 2.8 fails to compile two test programs
Date Sat, 09 Mar 2002 10:43:33 GMT

Hi,

	I ran into two problems when I tried to run the test suite
on Solaris 2.8.

apr% make test

/bin/sh libtool --silent --mode=compile cc -g -DHAVE_CONFIG_H -DSOLARIS2=8 -D_POSIX_PTHREAD_SEMANTICS
-D_REENTRANT   -I../include  -c testrand.c && touch testrand.lo
"testrand.c", line 62: #error: Random support is not available.  Go punt.
cc: acomp failed for testrand.c


/bin/sh libtool --silent --mode=link cc -g -DHAVE_CONFIG_H -DSOLARIS2=8 -D_POSIX_PTHREAD_SEMANTICS
-D_REENTRANT   -I../include -xildoff -o testatomic testatomic.lo ../libapr.la   -lsendfile
-lm -lsocket -lnsl  -ldl
Undefined                       first referenced
 symbol                             in file
apr_atomic_set                      testatomic.o
apr_atomic_cas                      testatomic.o
apr_atomic_init                     testatomic.o
apr_atomic_add                      testatomic.o
apr_atomic_inc                      testatomic.o
ld: fatal: Symbol referencing errors. No output written to testatomic
make[1]: *** [testatomic] Error 1


This is from apr obtained via cvs update at March 09 @ 1:00am

% uname -a
SunOS multivac 5.8 Generic_108528-13 sun4u sparc SUNW,Ultra-4

% cc -V
cc: WorkShop Compilers 4.2 30 Oct 1996 C 4.2


				Max Okumoto


Mime
View raw message