apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thom May <t...@planetarytramp.net>
Subject Re: Symbol name consistency
Date Sun, 17 Mar 2002 22:48:56 GMT
* Sander Striker (striker@apache.org) wrote :
> > From: Thom May [mailto:thom@planetarytramp.net]
> > Sent: 17 March 2002 23:09
[...]
> 
> > +apr_file_stat                    from apr_stat
> > +apr_file_lstat                   from apr_lstat
> 
> No need for 'file', the stat and lstat functions show
> their file relatedness by theirselves IMO.  Although
> for consistency I see your point. :(
> 
Mmmm. I realise most people know that stat and lstat are file operations,
but I was thinking in terms of consistency having special cases just because
it's obvious now is probably a bad thing...

> > +apr_file_path_root               from apr_filepath_root
> > +apr_file_path_merge              from apr_file_path_merge
> > +apr_file_path_set                from apr_filepath_set
> > +apr_file_path_get                from apr_filepath_get
> 
> Not sure.  I mean, not sure if 'file' is appropiate here.
> path may just be enough.
>
sure. so apr_path_root et all then?
 
> > +apr_file_attrs_t                 from apr_fileattrs_t
> > +apr_file_seek_where_t            from apr_seek_where_t
> 
> +1
> 
> > +                                 from apr_is_fnmatch
> 
> ??
> 

I didn't have a clue what to rename it to, but it needs renaming ;-)

> > +
> > +/* TODO: I'm not sure this is the best place to put this prototype...*/ apr_generate_random_bytes

Thoughts on where this one should be?
> > +
> 

[...]
> > +apr_network_service_byname_get   from apr_getservbyname
> > +apr_network_ip_subnet_create     from apr_ipsubnet_create
> > +apr_network_ip_subnet_test       from apr_ipsubnet_test
> > +apr_network_socket_inherit_set   from apr_socket_set_inherit
> > +apr_network_socket_inherit_unset from apr_socket_unset_inherit
> 
> Why put the word network in?  Seems like we would have to
> start typing that word a bit too often if you ask me.  I
> personally think that most people know that these function
> are network related, since their non-apr twins are aswell.
>
Agreed, but again in terms of consistency I felt I should list them.
 
> > +apr_pool_alloc                   from apr_palloc
> > +apr_pool_alloc_debug             from apr_palloc_debug
> > +apr_pool_calloc                  from apr_pcalloc
> > +apr_pool_calloc_debug            from apr_pcalloc_debug
> 
> Since this is used so often, apr_palloc is fine.  I don't think
> anyone would want a longer name for pools allocations.  I
> certainly don't.
>
Sure.
 
Cheers,
-Thom

Mime
View raw message