apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Erenkrantz <jerenkra...@ebuilt.com>
Subject Re: cvs commit: apr CHANGES Makefile.in apr-config.in configure.in
Date Tue, 12 Mar 2002 03:24:57 GMT
On Sun, Mar 10, 2002 at 03:54:12PM -0800, Greg Stein wrote:
> On Sat, Mar 09, 2002 at 07:26:13PM -0000, jerenkrantz@apache.org wrote:
> > jerenkrantz    02/03/09 11:26:13
> > 
> >   Modified:    .        CHANGES Makefile.in apr-config.in configure.in
> >   Log:
> >   Allow APR to install its own libtool into an installbuilddir.
> >   
> >   Add --with-installbuilddir to configure.
> 
> Why does it have the --with on there? Normally, --with means "use this
> package". Another comparison point is that all the other directory options
> to not have --with: --bindir, --libdir, --includedir, etc
> 
> I'd recommend changing it to just --installbuilddir. But all of those are
> installation directories, so it is really just --builddir.

As Aaron pointed out, I think there is no standard way of telling
autoconf to use a macro that doesn't have --with or --enable.  I
called it installbuilddir to match what httpd-2.0 calls the argument
with the same meaning.

If you know of a way to do that, feel free to add this.  Since
APR does not have access to any of the new parsing m4 code and
that code doesn't handle this argument anyway, this seemed the
best way.  Feel free to hack at it.  

I was able to fix my problem, but I won't have any time to do
anything much (besides lurk) for a few weeks.  -- justin


Mime
View raw message