apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sander Striker" <stri...@apache.org>
Subject FW: [PATCH] apr-util patch for wierd crash problem
Date Wed, 16 Jan 2002 09:51:07 GMT
-----Original Message-----
From: Jay Freeman (saurik) [mailto:saurik@saurik.com]
Sent: 16 January 2002 10:39
To: svn-dev
Subject: [PATCH] apr-util patch for wierd crash problem


OK, I finally figured out what was going on.  The configure scripts for apr-util are incorrectly
referencing -ldb4 rather
than -ldb-4 (which is what db4 actually installs as).

Index: srclib/apr-util/build/apu-conf.m4
===================================================================
RCS file: /home/cvspublic/apr-util/build/apu-conf.m4,v
retrieving revision 1.24
diff -u -r1.24 apu-conf.m4
--- srclib/apr-util/build/apu-conf.m4   2 Jan 2002 23:59:26 -0000       1.24
+++ srclib/apr-util/build/apu-conf.m4   16 Jan 2002 09:37:29 -0000
@@ -142,9 +142,9 @@
 dnl
 AC_DEFUN(APU_CHECK_DB4,[
 AC_CHECK_HEADER(db4/db.h, [
-  AC_CHECK_LIB(db4, db_create, [
+  AC_CHECK_LIB(db-4, db_create, [
   apu_db_header=db4/db.h
-  apu_db_lib=db4
+  apu_db_lib=db-4
   apu_db_version=4
   ])])
 if test "$apu_db_version" != "4"; then

Even though everything SEEMED to be building against db4, it apparently wasn't.

Sincerely,
Jay Freeman (saurik)
saurik@saurik.com


Mime
View raw message