apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sander Temme <scte...@covalent.net>
Subject Re: Another darwin/10.1 problem
Date Sat, 05 Jan 2002 19:30:33 GMT
>  I'm guessing here that mod_access.so was build as a library and not as
> a bundle.  Run file on the .so to find out.  It should say "Mach-O

Yup there's a problem:

[monalisa:/tmp/apache2/modules] sctemme% file mod_access.so
mod_access.so: Mach-O dynamically linked shared library ppc

>  If this is the problem, the .so's aren't being linked properly ("cc
> -bundle" not "cc -dynamiclib").  One thing to look for is GNU libtool
> should be getting the -module flag when building modules, or it will
> make this mistake.

Happens only on my laptop... Which, I now realize, has libtool 1.4.2
installed:

[monalisa:~/projects/httpd-2.0] sctemme% srclib/apr/libtool --version
ltmain.sh (GNU libtool) 1.4.2 (1.922.2.53 2001/09/11 03:18:52)

Here's a module link line:

/bin/sh /Users/sctemme/projects/httpd-2.0/srclib/apr/libtool --silent
--mode=link cc  -g -Wall -Wmissing-prototypes -Wstrict-prototypes
-Wmissing-declarations -DNO_DBM_REWRITEMAP  -DDEBUG -O0  -DDARWIN
-DSIGPROCMASK_SETS_THREAD_MASK -traditional-cpp -DAP_DEBUG
-DAP_HAVE_DESIGNATED_INITIALIZER   -I.
-I/Users/sctemme/projects/httpd-2.0/os/unix
-I/Users/sctemme/projects/httpd-2.0/server/mpm/prefork
-I/Users/sctemme/projects/httpd-2.0/modules/http
-I/Users/sctemme/projects/httpd-2.0/modules/proxy
-I/Users/sctemme/projects/httpd-2.0/include
-I/Users/sctemme/projects/httpd-2.0/srclib/apr/include
-I/Users/sctemme/projects/httpd-2.0/srclib/apr-util/include
-I/Users/sctemme/projects/httpd-2.0/modules/dav/main -export-dynamic
-o mod_auth.la -rpath /tmp/apache2/modules -module -avoid-version
mod_auth.lo 

Yes, -module is present. We're good. Have to be, we build correctly with the
Apple-supplied glibtool 1.3.5 with -flat_namespace. Libtool 1.4.2 may be not
so good:

/Users/sctemme/projects/httpd-2.0/srclib/apr/libtool: parse error: condition
expected: xyes = [3183]

This line has to do with enabling the $archive_cmds options, which should be
set around line 184 of the generated libtool. That in turn has the
conditional checking for the module parameter and should invoke -bundle if
so. This may not be happening.

Yeah. Moved the 1.4.2 libtool goodness out of the way and rebuilt with the
standard one. Works. Semi-false alarm. We love libtool.

S.

-- 
Covalent Technologies                             sctemme@covalent.net
Engineering group                                Voice: (415) 536 5214
645 Howard St.                                     Fax: (415) 536 5210
San Francisco CA 94105

   PGP Fingerprint: 1E74 4E58 DFAC 2CF5 6A03  5531 AFB1 96AF B584 0AB1

=======================================================
This email message is for the sole use of the intended recipient(s) and may
contain confidential and privileged information. Any unauthorized review,
use, disclosure or distribution is prohibited.  If you are not the intended
recipient, please contact the sender by reply email and destroy all copies
of the original message
=======================================================


Mime
View raw message