apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@attglobal.net>
Subject adding library dependencies to libtool links
Date Fri, 14 Dec 2001 14:12:06 GMT
Justin already convinced me that I ended up with the same result in
apr's Makefile.in with a change I put in for AIX.

This a.m. I tried Justin's apr-util change, hoping that it would work
since I have changed the flavor of linking we use on AIX to match the
flavor preferred by the folks who do libtool development on AIX.

Here is the specific change I applied to apr-util:

Index: srclib/apr-util/Makefile.in
===================================================================
RCS file: /cvs/apache/apr-util/Makefile.in,v
retrieving revision 1.53
diff -u -r1.53 Makefile.in
--- Makefile.in 2001/12/11 17:46:32     1.53
+++ Makefile.in 2001/12/14 14:05:27
@@ -6,6 +6,7 @@
 INCLUDES=-I./include -I../include -I@APR_SOURCE_DIR@/include

 TARGET_LIB = libaprutil.la
+DEPEND_LIBS=@LIBS@
 INSTALL_SUBDIRS = @APR_XML_DIR@

 TARGETS = delete-lib $(TARGET_LIB) delete-exports aprutil.exp
 export_vars.h
@@ -58,7 +59,7 @@

 $(TARGET_LIB):
        @objects="`find $(SUBDIRS) -name expat -prune -o -name
        'gen_uri_delims.@so_ext@' -prune -o -name '*.@s\
o_ext@' -print`"; \
-           tmpcmd="$(LINK) @lib_target@ @EXTRA_OS_LINK@"; \
+           tmpcmd="$(LINK) @lib_target@ @EXTRA_OS_LINK@
        $(DEPEND_LIBS)"; \
            echo $$tmpcmd; \
            $$tmpcmd

I get a lot further now...  libtool doesn't die doing the link of
libaprutil.la.  But... I'm getting errors at make install time.

Unexpected messages (maybe there are others... this was just from a
brief glance):

libtool: install: warning: relinking `libaprutil.la'
xlc_r: 1501-228 input file /jeff/trawick/apacheinst/lib/libexpat.a not found
libtool: install: error: relink `libaprutil.la' with the above command before installing it
...
Making install in support
libtool: install: warning: `/jeff/trawick/apache/httpd-2.0/srclib/apr-util/libaprutil.la'
has not been install\
ed in `/jeff/trawick/apacheinst/lib'
(repeated for each of our utilities in support)
Installing build system files
libtool: install: warning: `/jeff/trawick/apache/httpd-2.0/srclib/apr-util/libaprutil.la'
has not been install\
ed in `/jeff/trawick/apacheinst/lib'

If I should have tested a different patch, please let me know.
-- 
Jeff Trawick | trawick@attglobal.net | PGP public key at web site:
       http://www.geocities.com/SiliconValley/Park/9289/
             Born in Roswell... married an alien...

Mime
View raw message