apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Branko ─îibej <br...@xbc.nu>
Subject Re: building apr on windows
Date Mon, 10 Dec 2001 02:31:21 GMT
Brian Adams wrote:

>hi folks, I am trying to build the latest apr from cvs on windows and the
>win32 instructions do not work.
>I am using vs6.0 
>when I run 
>C:\downloads\tomcat\apr-util>msdev aprutil.dsw /MAKE "apriconv - Win32
>Debug" "apr - Win32 Debug" "libapr - Win32 Debug" "gen_uri_delims - Win32
>Debug" "xml - Win32 Debug" "aprutil - Win32 Debug"
>I get this:
>Warning: ignoring unknown project: aprutil - Win32 Debug
>Warning: ignoring unknown project: xml - Win32 Debug
>Warning: ignoring unknown project: gen_uri_delims - Win32 Debug
>Warning: ignoring unknown project: libapr - Win32 Debug
>Warning: ignoring unknown project: apr - Win32 Debug
>Warning: ignoring unknown project: apriconv - Win32 Debug
>Error: There are no valid targets to build.
>
>did I do something wrong or are the dsp and dsw files broken?
>
You used a version of cvs (probably from cygwin) that checked out those 
files with Unix (\n) line endings instead of DOS (\r\n) line endings. 
Msdev is very particular about line endings in project files.

You'r best bet is using the cvs binary available on http://cvshome.org, 
which does line conversions correctly.

(Mounting your sandbox in text mode under cygwin might work, ymmv)

>
>
>I have cygwin on this box also will this work?
>Thanks,
>Brian
>
>


-- 
Brane ─îibej   <brane@xbc.nu>   http://www.xbc.nu/brane/




Mime
View raw message