apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Erenkrantz <jerenkra...@ebuilt.com>
Subject Re: [PATCH] apu-conf (fix for Berkeley DB)
Date Mon, 03 Dec 2001 23:01:37 GMT
On Mon, Dec 03, 2001 at 02:30:04PM -0800, Ian Holsman wrote:
> this fix works for me on linux rh7.2
> and Solaris 8 
> the previous version failed if db2 didn't exist which would happen if
> it wasn't installed, and db3 was.
> 
> BTW db_open doesn't exist in db3, but db_version exists in 2/3 and not
> in 1.
> 
> Can some other people pls test this on their configs as I don't want to
> screw you over (again)

How about checking for db2 and then db?

AC_SEARCH_LIBS(db_version, [db2 db], [ 
    apu_have_db=1 
    db_header=db.h])
           
AC_SEARCH_LIBS has the side effect of setting LIBS (which may not
be desirable).  So, perhaps we want: 

AC_CHECK_LIB(db2, db_version, [
    apu_have_db=1
    db_header=db.h
    db_lib=db2 ], [
    AC_CHECK_LIB(db, db_version, [
        apu_have_db=1
        db_header=db.h
        db_lib=db ])
    ])

But, we need to prefer db2 over db.  -- justin


Mime
View raw message