apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@covalent.net>
Subject Re: Mod-ssl and latest tree and Win2K.
Date Tue, 16 Oct 2001 14:50:01 GMT
From: "P. Dwayne Miller" <dmiller@espgroup.net>
Sent: Tuesday, October 16, 2001 7:20 AM


> I can not seem to get the latest tree to work with SSL.  Everything 
> seems to compile okay, but...
> 
> when I run apache.exe, where it used to ask twice for the passphrase 
> (1.3.20), it only asks once.

Interesting.  We probably detached from the console before it asked, or the
new schema really fixed things.

In any case, Win32 really never supported passphrases well, you are
advised to remove them.  The problem gets very serious as a service, since
when the parent process refuses to start 'on time', the service is terminated.
That window is only two minutes, plenty in CPU time, but insufficient for
a human being who stepped away for coffee.

> And, any attempt to load a page results in one of the apache processes 
> chewing about 50-80% CPU, but nothing seems to happen.

Not good, I'm looking.  Try decrypting the key and see if that solves your
headache.

> Is there any log I can check that might be identifying an SSL problem? 
>  BTW, if I disable all of the SSL stuff in the config file and run as a 
> normal server, everything seems to work fine.

Sure, the sslenginelog at info or debug level will give you more detail
than you _ever_ wanted to know :)

SSLLog      logs/ssl_engine_log
SSLLogLevel debug

> I'm compiling and running on Win2K, using VisualStudio environment.  I'm 
> building using the *.dsw workspace files.  I've tried using the 
> makefile.win, but no difference.

And it shouldn't make a difference.  Because we can't toggle a project on
a case-by-case basis, 

> Also, I cannot seem to get the workspace based build to replicate the 
> 'installx' option of the makefile (i.e. it does not copy and move 
> everything into the \apache2 directory.  Any help there?

It should, please identify missing files/directories and I'll get the changes
committed today.

> The last bit of info that I can provide is that I'm starting the 
> apache.exe from a command window, logged in as a non-administrator user.

Shouldn't matter (except for the passphrase issue.)


Mime
View raw message