apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cliff Woolley <cliffwool...@yahoo.com>
Subject Re: FW: stdint.h not found when compiling apr in webapp 1.0 (tc4.0)
Date Sun, 23 Sep 2001 22:29:22 GMT
On Sun, 23 Sep 2001, Pier Fumagalli wrote:

> > Making all in strings
> > /bin/sh
> > /usr/home/gcom/webapp-module-1.0-tc40/apr/libtool --silent --mode=compile
> > cc -g -O2   -DHAVE_CONFIG_H -D_REENTRANT -D_THREAD_SAFE   -I../include -I../
> > include/arch/unix  -c apr_cpystrn.c && touch apr_cpystrn.lo
> > In file included from apr_cpystrn.c:55:
> > ../include/apr.h:132: stdint.h: No such file or directory
> > *** Error code 1
>
> FYI... From Thursday CVS snapshot...

I sure can't figure out how this would happen... stdint.h is only included
by apr.h if configure decided that stdint.h both existed and contained a
define for INT64_C that it wanted.  None of that stuff has changed in
forever anyway... did this just start happening?  It works fine for me
under Linux.  The only thing interesting I can find is that FreeBSD 4.3
doesn't seem to have stdint.h at all... maybe it's a quirk in 4.4?

--Cliff

PS: two things I noticed that don't really address this problem but that
should be fixed anyway: 1) APR_HAVE_STDINT_H is only set to 1 if it's
there _and_ we want it for INT64_C purposes.  It should be set to 1
regardless of the INT64_C thing if it's present.  2) APR_HAVE_STDINT_H is
missing from apr.hw.

--------------------------------------------------------------
   Cliff Woolley
   cliffwoolley@yahoo.com
   Charlottesville, VA




Mime
View raw message