apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Erenkrantz <jerenkra...@ebuilt.com>
Subject Re: unable to compile mod_webapp on Solaris 2.6 and 8 (apr related)
Date Fri, 28 Sep 2001 20:05:54 GMT
[ CCing dev@apr... ]

On Thu, Sep 27, 2001 at 09:49:39AM -0000, Stefan Majer wrote:
> Hi,
> 
> im trying to build the mod_webapp on Solaris 2.6

Oh, odd.  It looks like we're not detecting the shared memory
correctly on Solaris 2.6.  The only tool version not specified 
was autoconf's and that's the most important version to have
(should be 2.13+).  For grins, Stefan, can you rerun ./buildconf 
in the apr directory?

Cliff, don't you have Solaris 2.6?  Is everything building okay 
for you?  What option do we select for shmem on 2.6?  All of the 
Solaris 2.6 machines I had were mothballed.  =)   -- justin

> and get the following errors while configure for apr is
> running:
> 
> ##########################
> Checking for Shared Memory Support...
> 
> checking for sys/mman.h... no
> checking for MAP_ANON in sys/mman.h... no
> checking for mmap... yes
> checking for munmap... yes
> checking for shm_open... no
> checking for shm_unlink... no
> checking for /dev/zero... yes
> checking for sys/ipc.h... no
> checking for sys/shm.h... no
> checking for sys/file.h... no
> checking for shmget... yes
> checking for shmat... yes
> checking for shmdt... yes
> checking for shmctl... yes
> checking for kernel/OS.h... no
> checking for create_area... no
> checking for os2.h... no
> ./configure:Error: decision on shared memory allocation
> method failed
> #######################################
> 
> this is with 
> 
> webapp-module-1.0-tc40-src.tar.gz from the jakarta site
> and also with an actual 
> apr_20010926101907.tar.gz
> 
> bash-2.02# libtool --version
> ltmain.sh (GNU libtool) 1.4 (1.920 2001/04/24 23:26:18)
> bash-2.02# gcc -v
> Reading specs from
> /usr/local/lib/gcc-lib/sparc-sun-solaris2.6/2.95.3/specs
> gcc version 2.95.3 20010315 (release)
> bash-2.02# aclocal --version
> aclocal (GNU automake) 1.4
> 
> 
> Is the any chance to get the combination Apache-1.3 with
> ssl and tc-4 running on solaris ?
> 
> 
> 
> any help welcome
> 
> stefan majer
> x-cellent technologies gmbh
> munich germany


Mime
View raw message