apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Stein <gst...@lyra.org>
Subject Re: FW: Autoconf 2.5/Libtool 1.4 problem...
Date Sat, 22 Sep 2001 10:29:11 GMT
See my recent post. I've got SVN working with 2.52 and 1.4.2. I had no
problems with shared libraries or linking. The problems were related to
libtool's "relink" behavior at install time. It is buggy, so I wrote a
workaround. Works, but I'm hoping somebody has a better solution before I go
and commit.

So... it could be that APR is doing Something Bad and making the combo not
work right.

Cheers,
-g

On Sat, Sep 22, 2001 at 09:32:58AM +0200, Sander Striker wrote:
> Hi,
> 
> This appeared on the apr list, and it seemed appropiate to
> forward it since subversion is trying to upgrade to this
> very combination.
> 
> Mo, Greg, you want to investigate this further?
> 
> Sander
> 
> -----Original Message-----
> From: Justin Erenkrantz [mailto:jerenkrantz@ebuilt.com]
> Sent: 22 September 2001 05:44
> To: dev@apr.apache.org
> Subject: Autoconf 2.5/Libtool 1.4 problem...
> 
> 
> On my Mandrake-based systems (seen on 7.2 and Cooker), libtool 1.4 
> and autoconf 2.52 (reproducable with the stock gnu.org versions) 
> interact to cause shared libraries not to work.  I haven't been 
> able to find out exactly what the cause is here.  (I'll attempt to 
> dig in more as time allows...)
> 
> With libtool 1.4, this results in a non-buildable tree (as it 
> tries to use -soname which is not supported by gcc).  Libtool 
> 1.4.2 is a bit better, but refuses to build shared libraries at 
> *all* (but the tree is buildable - we'll just *silently* ignore 
> any requests for shared libraries - which is bad).
> 
> The kicker here is that this problem doesn't occur with autoconf 
> 2.13/libtool 1.4 or autconf 2.52/libtool 1.3.3 (libtool complains
> about an unexpected = in this combination, but builds okay).  I 
> just tested with autoconf 2.50/libtool 1.4.2 and this combination 
> looks broken too.
> 
> Can anyone else reproduce this?  Should we force buildconf to forbid
> this combination (autoconf 2.50+ and libtool 1.4+)?  -- justin
> 
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
> For additional commands, e-mail: dev-help@subversion.tigris.org

-- 
Greg Stein, http://www.lyra.org/

Mime
View raw message