apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Doug MacEachern <do...@covalent.net>
Subject apr_uri naming
Date Wed, 01 Aug 2001 21:48:50 GMT
the UNP_* flags should probably have an APR_URI_ (or APU_URI_?) prefix.
whats with APU_URI anyhow, if we have apr_uri_components.  doesn't matter
to me which, but it should be one or the other, apu or apr?

and the in the move, the functions were not properly renamed, eg.
apr_uri_unparse_components should be apr_uri_components_unparse
apr_uri_parse_components should be apr_uri_components_parse

tho i'd be even more happy with apr_uri_unparse, apr_uri_parse, etc.
i'm sure everybody is just as tired of renaming stuff, but now is the
time.  how about the following?

#old                                new
APU_URI_*                           APR_URI_*
UNP_OMITUSER                        APR_URI_UNP_OMITUSER
UNP_OMITPASSWORD                    APR_URI_UNP_OMITPASSWORD
UNP_OMITUSERINFO                    APR_URI_UNP_OMITUSERINFO
UNP_REVEALPASSWORD                  APR_URI_UNP_REVEALPASSWORD
UNP_OMITPATHINFO                    APR_URI_UNP_OMITPATHINFO
UNP_OMITQUERY                       APR_URI_UNP_OMITQUERY
apr_uri_components                  apr_uri_t
apr_uri_unparse_components          apr_uri_unparse
apr_uri_parse_components            apr_uri_parse
apr_uri_parse_hostinfo_components   apr_uri_parse_hostinfo


Mime
View raw message