apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <traw...@attglobal.net>
Subject Re: [PATCH] make socket timeouts work reasonably for connect()
Date Tue, 10 Jul 2001 17:05:50 GMT
Cliff Woolley <cliffwoolley@yahoo.com> writes:

> (apr_wait_for_io_or_timeout() might want a better name if it's going
> public, but that's just a nit)

It definitely isn't intended to be public (not to be called by apr
app, not in public header file) but it is prefixed with apr_ for
namespace protection reasons.

We might want to use a special prefix like apr_pvt_ for symbols like
this which are only for APR to use internally.  I dunno...

-- 
Jeff Trawick | trawick@attglobal.net | PGP public key at web site:
       http://www.geocities.com/SiliconValley/Park/9289/
             Born in Roswell... married an alien...

Mime
View raw message