apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jean-frederic clere <jfrederic.cl...@fujitsu-siemens.com>
Subject Re: libapr and --disable-shared?
Date Thu, 05 Jul 2001 07:37:46 GMT
"Pier P. Fumagalli" wrote:
> 
> (me dumb when no reply-to header)
> 
> Justin Erenkrantz at jerenkrantz@ebuilt.com wrote:
> >
> > [ Moving to dev@apr ]
> 
> >From where ? :)
> 
> > On Wed, Jul 04, 2001 at 05:48:42PM -0700, rbb@covalent.net wrote:
> >>
> >> APR doesn't install the library correctly yet.  Until we fix that, we need
> >> to use disable shared.  It is in the STATUS file to fix the install, and
> >> make APR a useful external library.  :-)
> >>
> >> BTW, which packages are you refering to?  The only ones I know of
> >> currently are Apache 2.0 and Subversion.  I would love to get a collection
> >> of known packages using APR.
> >
> > mod_webapp from Tomcat 4.0 relies on APR.  And, they require an
> > installed version of APR.  They don't believe that the installation
> > doesn't work.  =)  (I tried convincing them otherwise...)
> 
> Yeah, that's a pain...
> 
> > I think Pier is working on switching mod_webapp to use the source, but I
> > think J.F. Clere has voted against that in tomcat-dev (not sure though,
> > he can prolly correct me if I'm misinterpreting his statements).
> 
> I'm going to do it... And if he remembers his -1, he'll roll back :)

Well, I said that the problems we had in mod_webapp due to APR should be solved
in APR not in mod_webapp.
I think that not a -1 for using APR sources instead APR installation. It is just
a matter of configure/makefiles I am sure Pier will not -1 a proposal to support
both APR sources and APR installation in mod_webapp.

I am also worried with mod_webapp for Apache-2.0, what will happend when a
internal typedef of APR comming from httpd will be used by mod_webapp and will
be handled differently there because of different APR version?

> Out
> tomorrow or Friday...

I am not every happy to use APR sources in mod_webapp, because I use a "libapr
and --disable-shared" for mod_webapp on my test platforms (Linux and
ReliantUnix).

It did not work because APR needs some "system libraries". To work-around this
problem I have added a LDFLAGS/CFLAGS in mod_webapp makefiles for that. I think
that the information about which "system libraries" are neeed should be provided
by APR in APRVARS. 

I have also tried with a shared libapr, but that was some weeks ago. I remember
MM problems and some "system library missing".

> 
>     Pier

Mime
View raw message