apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cliff Woolley <cliffwool...@yahoo.com>
Subject Re: cvs commit: apr/misc/unix errorcodes.c
Date Tue, 05 Jun 2001 16:42:55 GMT
On Tue, 5 Jun 2001, David Reid wrote:

> >   * Remove the unnecessary parameter checks and the extra error codes that
> >     went along with them.  The APR policy is to segfault on a NULL
> >     parameter
> >     rather than silently returning some error code that the caller might
> >     not check anyway.
>
> Can't say I agree 100% with this, but if you say so, it must be.  BTW, where
> is this written/documented??

I don't know if it IS documented, but I've been told this a thousand times
by various people since I came on board, and I've never once been told
the opposite.  <shrug>


> >   * Fix a misnamed APR_MEMORY_ASSERT -> APR_ASSERT_MEMORY, which was
> >     causing
> >     apr_assert_memory() never to be compiled.  Also fix a syntax error in

s/apr_assert_memory/apr_sms_assert/

So sue me.


> >     that
> >     function that's been there since rev 1.1 of apr_sms.c, which no one's
> >     ever noticed because they never compiled it before.
>
> If you checked you'd see that the misnamed assert tag was added in revision
> 1.5 of the original file, and so the code that you claim was never built was
> building quite happily up till that point.  As for the screw up on the
> naming, don't believe I missed that!

Huh?  I did check.  The misnamed tag and the missing semicolon had both
been there since rev 1.1 of apr_sms.c.  Which file are you talking about?
So anyway, apr_sms.c was using both APR_MEMORY_ASSERT and
APR_ASSERT_MEMORY since rev 1.1, but only APR_ASSERT_MEMORY was ever
actually defined by configure.  <shrug>  Oh well.  No big deal.  It's
fixed now.

Look, I wasn't trying to irritate anybody with this commit (or commit
message, for that matter).  The commit message was only meant to point out
that I'd found a typo and tried to fix it so that somebody would know to
look closely at that part of the commit.  Sander did so, found that I'd in
fact made a mistake, and I fixed it.  That's what this is all about.  As
for the commit, I was just trying to implement what seemed to be the
collective will of the group given what's been said by Greg, Jeff, Justin,
myself, and others.  That's all.  If it came off as a personal thing, I
apologize... that wasn't the intent.

--Cliff


--------------------------------------------------------------
   Cliff Woolley
   cliffwoolley@yahoo.com
   Charlottesville, VA




Mime
View raw message