apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cliff Woolley <cliffwool...@yahoo.com>
Subject RE: cvs commit: apr-util/test testdate.c
Date Wed, 06 Jun 2001 21:34:42 GMT
On Wed, 6 Jun 2001, Ian Holsman wrote:

> should apr_checkmask be called apr_date_checkmask?
> mod_proxy uses it to do ap_checkmask(buf, "HTTP/#.# ###*")

> >     * @deffunc int apr_checkmask(const char *data, const char *mask)
> >     */
> >   -APU_DECLARE(int) apr_checkmask(const char *data, const char *mask);
> >   +APU_DECLARE(int) apr_date_checkmask(const char *data,

That's a good question.  Until we answer it, to be consistent, I fixed the
@deffunc docco to say "apr_date_checkmask" before I forgot about it.
(I attributed it to you because I wouldn't have spotted it if you
hadn't asked about the function. :-)

I'm open to the possibility that apr_*_checkmask has more functionality
than just date masks, meaning it should have a more generic name...
anybody have an opinion one way or the other?


   Cliff Woolley
   Charlottesville, VA

View raw message