apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Erenkrantz <jerenkra...@ebuilt.com>
Subject Re: cvs commit: apr-util/test testdate.c
Date Wed, 06 Jun 2001 22:56:02 GMT
On Wed, Jun 06, 2001 at 05:34:42PM -0400, Cliff Woolley wrote:
> On Wed, 6 Jun 2001, Ian Holsman wrote:
> 
> > should apr_checkmask be called apr_date_checkmask?
> >
> > mod_proxy uses it to do ap_checkmask(buf, "HTTP/#.# ###*")
> 
> > >     * @deffunc int apr_checkmask(const char *data, const char *mask)
> > >     */
> > >   -APU_DECLARE(int) apr_checkmask(const char *data, const char *mask);
> > >   +APU_DECLARE(int) apr_date_checkmask(const char *data,
> 
> 
> That's a good question.  Until we answer it, to be consistent, I fixed the
> @deffunc docco to say "apr_date_checkmask" before I forgot about it.
> (I attributed it to you because I wouldn't have spotted it if you
> hadn't asked about the function. :-)
> 
> I'm open to the possibility that apr_*_checkmask has more functionality
> than just date masks, meaning it should have a more generic name...
> anybody have an opinion one way or the other?

My bad.  I guess I missed that scandoc thing.  Thanks for catching it.

My sentiments are pretty much what Cliff said.  It is in the 
apr_date.c file, so I renamed it to apr_date_checkmask to be consistent.

If someone want to yank it out into another file, I'll accept
patches.  But, it'll require more changes to the DSPs - our favorite
thing to do.  -- justin


Mime
View raw message