apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pier P. Fumagalli" <p...@betaversion.org>
Subject Re: Problems with APR under Linux...
Date Sat, 19 May 2001 00:05:17 GMT
Pier P. Fumagalli at pier@betaversion.org wrote:

> jean-frederic clere at jfrederic.clere@fujitsu-siemens.com wrote:
> 
>> "Pier P. Fumagalli" wrote:
>>> 
>>> I'm a dork, I sent it only to Bill without including the mailing list...
>>> Damn lack of a Reply-To header :) :)
>>> 
>>>     Pier
>>> 
>>> [jreilly@lorien bin]$ ./httpd
>>> Syntax error on line 957 of /usr/local/apache/conf/httpd.conf:
>>> Cannot load /usr/local/apache/libexec/mod_webapp.so into server:
>>> /usr/local/apache/libexec/mod_webapp.so: undefined symbol: pthread_sigmask
>>> [jreilly@lorien bin]$
>>> 
>>> That's weird... Do anyone knows where this one could come from? It seems
>>> that pthread_sigmask is not found when talking about Linux, but that seems
>>> really strange, since I don't use any threading function per se in WebApp...
>>> (Might be called from apr_initialize?)
>> 
>> I have no found exactly what happends but just add -lpthread in the
>> (tomcat-connectors)/Makefile solves the problem:
> 
> Ok, will add that into our autoconf/automake stuff. :) Thanks for the
> hint...
> 
>   Pier

Jean-Federic  told me that the trick works for Linux, but not for other
systems such as Reliant Unix... Is there a way to find out on which
libraries APR relies on?

    Pier


Mime
View raw message