apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jean-frederic clere <jfrederic.cl...@fujitsu-siemens.com>
Subject Re: Problems with APR under Linux...
Date Fri, 18 May 2001 14:19:07 GMT
"Pier P. Fumagalli" wrote:
> 
> I'm a dork, I sent it only to Bill without including the mailing list...
> Damn lack of a Reply-To header :) :)
> 
>     Pier
> 
> [jreilly@lorien bin]$ ./httpd
> Syntax error on line 957 of /usr/local/apache/conf/httpd.conf:
> Cannot load /usr/local/apache/libexec/mod_webapp.so into server:
> /usr/local/apache/libexec/mod_webapp.so: undefined symbol: pthread_sigmask
> [jreilly@lorien bin]$
> 
> That's weird... Do anyone knows where this one could come from? It seems
> that pthread_sigmask is not found when talking about Linux, but that seems
> really strange, since I don't use any threading function per se in WebApp...
> (Might be called from apr_initialize?)

I have no found exactly what happends but just add -lpthread in the
(tomcat-connectors)/Makefile solves the problem:
+++Index: Makefile.in
===================================================================
RCS file:
/home/cvs/mirror/jakarta-tomcat-4.0/connectors/apache-1.3/Makefile.in,v
retrieving revision 1.1
diff -u -r1.1 Makefile.in
--- Makefile.in 2001/05/10 06:13:29     1.1
+++ Makefile.in 2001/05/18 13:38:27
@@ -68,7 +68,7 @@
 
 mod_webapp.so:
        @echo Linking Apache 1.3.x module
-       @$(APXS) -c $(APXSFLAGS) mod_webapp.c
+       @$(APXS) -c $(APXSFLAGS) -lpthread mod_webapp.c
 
 clean:
        @echo Removing object files $(OBJS) $(MODULE)                           
+++

An other solution would be to use an APR without threads. To do so use
"./configure --enable-threads=no" when configuring APR.
 

> 
> It works under MacOS X :)
> 
>     Pier

Mime
View raw message