apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Laurie <...@algroup.co.uk>
Subject Re: New memory code renaming
Date Fri, 11 May 2001 08:43:35 GMT
David Reid wrote:
> 
> Why memsys???  I'm sorry I just don't follow the logic. The code deals with
> memory doesn't it?
> 
> > On Thu, May 10, 2001 at 01:54:51AM +0100, David Reid wrote:
> > > Does anyone have any objections to simply calling this stuff
> > > apr_memory_blah?
> > >
> > > That'll give us
> > >
> > > apr_memory_malloc
> > > apr_memory_realloc
> > > apr_memory_free
> > > apr_memory_is_tracking
> > > apr_memory_create
> > > apr_memory_reset
> > > apr_memory_destroy
> > > apr_standard_memory_create
> > > apr_tracking_memory_create
> > > etc...
> >
> > prefer memsys, it says more.
> 
> Do we need to say more?  Do users really care?

Users may not care, but programmers do :-)

The only reason I care is that it doesn't make sense to me to use a word
for something that so many other things could equally well use - so my
vote would be for sms :-)

Cheers,

Ben.

--
http://www.apache-ssl.org/ben.html

"There is no limit to what a man can do or how far he can go if he
doesn't mind who gets the credit." - Robert Woodruff

Mime
View raw message