apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Reid" <dr...@jetnet.co.uk>
Subject New memory code renaming
Date Thu, 10 May 2001 00:54:51 GMT
Does anyone have any objections to simply calling this stuff
apr_memory_blah?

That'll give us

apr_memory_malloc
apr_memory_realloc
apr_memory_free
apr_memory_is_tracking
apr_memory_create
apr_memory_reset
apr_memory_destroy
apr_standard_memory_create
apr_tracking_memory_create
etc...

all using a type apr_memory_t

This seems to make more sense and is short enough I think.  If I don't hear
any objections I'll try to make the change over the weekend while in
Montreal.

Also, do we plan on making the plug-ins modular so they can be loaded at run
time?  Just a thought...

david


Mime
View raw message