apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Reid" <dr...@jetnet.co.uk>
Subject Re: New memory code renaming
Date Thu, 10 May 2001 10:54:20 GMT
Why memsys???  I'm sorry I just don't follow the logic. The code deals with
memory doesn't it?

> On Thu, May 10, 2001 at 01:54:51AM +0100, David Reid wrote:
> > Does anyone have any objections to simply calling this stuff
> > apr_memory_blah?
> >
> > That'll give us
> >
> > apr_memory_malloc
> > apr_memory_realloc
> > apr_memory_free
> > apr_memory_is_tracking
> > apr_memory_create
> > apr_memory_reset
> > apr_memory_destroy
> > apr_standard_memory_create
> > apr_tracking_memory_create
> > etc...
>
> prefer memsys, it says more.

Do we need to say more?  Do users really care?

>
> > This seems to make more sense and is short enough I think.  If I don't
hear
> > any objections I'll try to make the change over the weekend while in
> > Montreal.
> >
> > Also, do we plan on making the plug-ins modular so they can be loaded at
run
> > time?  Just a thought...
>
> yes, that was part of a plan, too.
>
> then you can publish the API, name the .so that you wish to be loaded.

OK, but it's a long way aways yet anyway...

david



Mime
View raw message