apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <trawi...@bellsouth.net>
Subject Re: cvs commit: apr-util/xml/expat configure.in
Date Fri, 30 Mar 2001 06:35:06 GMT
For reasons I can't explain, on systems with real libtool the minor
changes below result in a new buildconf message ("Remember to add
`AM_PROG_LIBTOOL' to `configure.in'.") for both configure.in files.

If I move the AC_PROG_LIBTOOL invocation to the beginning of the line
(i.e., just delete the four spaces) the messages go away.

The same spaces in apr/configure.in don't cause the message to be
generated.

Weird, huh?

bjh@apache.org writes:

>   Index: configure.in
>   ===================================================================
>   RCS file: /home/cvs/apr-util/configure.in,v
...
>   -AC_PROG_LIBTOOL
>   +
>   +AC_CANONICAL_SYSTEM
>   +case "$host_alias" in
>   +*os2*)
>   +    # Use a custom made libtool replacement
>   +    echo "using aplibtool"
>   +    LIBTOOL="$APR_SOURCE_DIR/build/aplibtool"
>   +    ;;
>   +*)
>   +    AC_PROG_LIBTOOL
>   +    ;;
>   +esac

>   Index: configure.in
>   ===================================================================
>   RCS file: /home/cvs/apr-util/xml/expat/configure.in,v
...
>   -AC_LIBTOOL_WIN32_DLL
>   -AC_PROG_LIBTOOL
>   +AC_CANONICAL_SYSTEM
>   +case "$host_alias" in
>   +*os2*)
>   +    # Use a custom made libtool replacement
>   +    echo Using aplibtool
>   +    LIBTOOL="$srcdir/../../../apr/build/aplibtool"
>   +    ;;
>   +*)
>   +    AC_LIBTOOL_WIN32_DLL
>   +    AC_PROG_LIBTOOL
>   +    ;;
>   +esac

-- 
Jeff Trawick | trawickj@bellsouth.net | PGP public key at web site:
       http://www.geocities.com/SiliconValley/Park/9289/
             Born in Roswell... married an alien...

Mime
View raw message