apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Stein <gst...@lyra.org>
Subject Re: cvs commit: apr-util configure.in
Date Fri, 09 Mar 2001 14:35:48 GMT
That is probably the stupid dependency stuff in build2.mk. httpd's buildconf
should unconditionally recurse.

But Martin's error is something else, I believe (see other note). I'm
testing a fix now.

Cheers,
-g

On Fri, Mar 09, 2001 at 06:25:40AM -0800, rbb@covalent.net wrote:
> 
> I have found recently, that buildconf doesn't really do what you expect in
> a lot of cases.  Namely, it doesn't tend to traverse into srclib/apr and
> srclib/apr-util, and run those buildconf's.  Try running those manually
> right now.  I was going to investigate further before posting the bug, but
> time isn't being kind to me.  :-)
> 
> Ryan
> 
> On Fri, 9 Mar 2001, Martin Kraemer wrote:
> 
> > On Fri, Mar 09, 2001 at 05:06:25AM -0800, Greg Stein wrote:
> > > No.
> > >
> > > We run xml/expat/configure, and it produces that Makefile. APRUTIL shouldn't
> > > be doing this. Please back out this change.
> >
> > That is not really true. It definitely did not generate the Makefile,
> > that's why I added the patch in the first place.
> >
> > I always do "buildconf && configure && make clean && make",
> > and "make clean" bailed out because the apr-util/xml/expat/Makefile
> > was not generated.
> >
> >     Martin.
> > --
> > <Martin.Kraemer@Fujitsu-Siemens.com>         |     Fujitsu Siemens
> > Fon: +49-89-636-46021, FAX: +49-89-636-41143 | 81730  Munich,  Germany
> >
> >
> 
> 
> _______________________________________________________________________________
> Ryan Bloom                        	rbb@apache.org
> 406 29th St.
> San Francisco, CA 94131
> -------------------------------------------------------------------------------

-- 
Greg Stein, http://www.lyra.org/

Mime
View raw message