apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Trawick <trawi...@bellsouth.net>
Subject Re: httpd-2.0 does not build -- missing apr_sigwait
Date Wed, 21 Feb 2001 10:26:31 GMT
Martin Kraemer <Martin.Kraemer@Fujitsu-Siemens.com> writes:

> The current apr is missing a macro apr_sigwait(), it is referenced in
> apr/threadproc/unix/signals.c, and I guess it must look somewhat
> similar to the following:
> 
> > #ifdef SIGWAIT_TAKES_ONE_ARG
> > #define apr_sigwait(a,b) sigwait(a)
> > #else
> > #define apr_sigwait(a,b) sigwait(a,b)
> > #endif

The return code of the single-parameter sigwait() is the signal
number (except -1 for error).  The second param of the
double-parameter sigwait() is updated with the signal number (except
in error case).

> Without this macro, httpd-2.0 doesn't build, because apr_sigwait is
> unresolved at link time.
> 
> I was going to commit this fix (Ryan had told me recently he had added
> me to the committers list), but alas:
>   **** Access denied: Insufficient Karma (martin|apr/threadproc/unix)
>   cvs server: Pre-commit check failed
>   cvs [server aborted]: correct above errors first!
>   cvs commit: saving log message in /tmp/cvssIKmf78601

I can't fix that but I will try to commit *something* Real Soon Now.
I will try to spend time debugging the new buildconf warnings before
testing any code though so no guarantees that the apr_sigwait() fix is
golden.

-- 
Jeff Trawick | trawickj@bellsouth.net | PGP public key at web site:
       http://www.geocities.com/SiliconValley/Park/9289/
             Born in Roswell... married an alien...

Mime
View raw message