apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <...@covalent.net>
Subject Re: cvs commit: apr configure.in
Date Mon, 26 Feb 2001 20:14:33 GMT

I like APR_FLAG_HEADERS personally.  I like the idea of having configure
just detect the variable name, but that means documenting what the
transformations are, and it keeps us from having control over the variable
name, which I kind of dislike.

Ryan

On Mon, 26 Feb 2001, Cliff Woolley wrote:

> On Mon, 26 Feb 2001, Jim Jagielski wrote:
>
> > >   Use APR_CHECK_HEADERS instead
> > >
> >
> > Before I go any further, I want to rethink the name. Maybe APR_FLAG_HEADERS
> > (want to avoid confusion here) or APR_HEADERS_SET. Suggestions
> > welcome.
>
> APR_CHECK_HEADERS doesn't bother me... it makes it clear that it serves
> basically the same purpose as AC_CHECK_HEADERS, but has added
> functionality for APR.
>
> It also wouldn't hurt my feelings any if APR_CHECK_HEADERS automagically
> determined the variable name to flag with a 1 or a 0 by doing basically
> this
>    s/\//_/g;
>    s/\.//g;
> on the header name.  Hence "sys/sendfile.h" becomes the flag variable
> "sys_sendfileh" automatically.  That would avoid typo problems like the
> one this morning, and it would be just one less step that's
> necessary.  The downside is that it implies a little bit of extra work in
> configure... <shrug>
>
> --Cliff
>
>


_______________________________________________________________________________
Ryan Bloom                        	rbb@apache.org
406 29th St.
San Francisco, CA 94131
-------------------------------------------------------------------------------


Mime
View raw message