apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <...@covalent.net>
Subject Re: monday morning breakage
Date Mon, 26 Feb 2001 16:32:00 GMT

Fix is on the way.  The problem is that we never subst into the apr.h
file, so APR_HAS_SENDFILE_H is defined to be @has_sendfile@ or something
like it.

Ryan

On 26 Feb 2001, Ben Collins-Sussman wrote:

>
> I just removed my apr/ subdir and checked it out fresh this morning.
> I'm getting this compile error on my FreeBSD 4.2 system:
>
> gmake[4]: Entering directory `/usr/home/sussman/projects/subversion/apr/network_io/unix'
> /bin/sh /usr/home/sussman/projects/subversion/apr/libtool --mode=compile --silent gcc
-g -O2 -g -Wall -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations  -I../../include
-I../../include/arch/unix -I../../include/arch/unix -c poll.c && touch poll.lo
> In file included from poll.c:55:
> ../../include/arch/unix/networkio.h:108: syntax error
>
>
> Here's line 108-110 of networkio.h:
>
> #if APR_HAVE_SYS_SENDFILE_H
> #include <sys/sendfile.h>
> #endif
>
> And, of course, my system has no <sys/sendfile.h>.  :)
>
> I know that there's been a recent thread on this list about
> sendfile.h, but I have to admit that I didn't read it. (*blush*)  Can
> anyone tell me what the problem is?  I assume that that
> APR_HAVE_SYS_SENDFILE_H is being defined when it shouldn't be.
>
>


_______________________________________________________________________________
Ryan Bloom                        	rbb@apache.org
406 29th St.
San Francisco, CA 94131
-------------------------------------------------------------------------------


Mime
View raw message