apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <...@covalent.net>
Subject Re: httpd-2.0 does not build -- missing apr_sigwait
Date Wed, 21 Feb 2001 06:35:24 GMT

That is in apr_private.h.in.  You will need to re-run configure to pick it
up.

This patch compiles just fine on my box.

Ryan

On Wed, 21 Feb 2001, Martin Kraemer wrote:

> The current apr is missing a macro apr_sigwait(), it is referenced in
> apr/threadproc/unix/signals.c, and I guess it must look somewhat
> similar to the following:
>
> > #ifdef SIGWAIT_TAKES_ONE_ARG
> > #define apr_sigwait(a,b) sigwait(a)
> > #else
> > #define apr_sigwait(a,b) sigwait(a,b)
> > #endif
>
> Without this macro, httpd-2.0 doesn't build, because apr_sigwait is
> unresolved at link time.
>
> I was going to commit this fix (Ryan had told me recently he had added
> me to the committers list), but alas:
>   **** Access denied: Insufficient Karma (martin|apr/threadproc/unix)
>   cvs server: Pre-commit check failed
>   cvs [server aborted]: correct above errors first!
>   cvs commit: saving log message in /tmp/cvssIKmf78601
>
>    Martin
> --
> <Martin.Kraemer@Fujitsu-Siemens.com>         |     Fujitsu Siemens
> Fon: +49-89-636-46021, FAX: +49-89-636-41143 | 81730  Munich,  Germany
>
>


_______________________________________________________________________________
Ryan Bloom                        	rbb@apache.org
406 29th St.
San Francisco, CA 94131
-------------------------------------------------------------------------------


Mime
View raw message