apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From do...@apache.org
Subject Re: add rename symbols to ap*_compat.h
Date Sun, 18 Feb 2001 21:44:00 GMT
On Sun, 18 Feb 2001, Greg Stein wrote:

> Doug,
> 
> In your big rename, you forgot to add the old->new name conversions to the
> ap*_compat.h files. (apu_compat and apr_compat)

the 1.3.x ap_* compat macros were updated to reflect the changes, e.g.
#define ap_make_array apr_make_array
 became
#define ap_make_array apr_array_make

are you looking for 2.0-only apr_old_name -> apr_new_name ?
api is subject to change before beta, i don't see any reason to provide
these.  or are you talking about something else?

btw, i missed one apr_clear_pool -> apr_pool_clear, ok to make that
change?


Mime
View raw message