apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dale Ghent <da...@elemental.org>
Subject Re: autoconf and Gnu m4... a matched set?
Date Wed, 28 Feb 2001 01:18:19 GMT
On Tue, 27 Feb 2001, Jim Jagielski wrote:

| According to the autoconf docs:
| 
|    Autoconf requires GNU `m4' in order to generate the scripts.  It
|    uses features that some UNIX versions of `m4' do not have.  It also
|    overflows internal limits of some versions of `m4', including GNU `m4'
|    1.0.  You must use version 1.1 or later of GNU `m4'.  Using version 1.3
|    or later will be much faster than 1.1 or 1.2.
| 
| Not sure how really true or relevant that is right now...

Things that were written with GNU m4 in mind have always blown up when I
tried using Solaris's /usr/ccs/bin/m4 instead.

I think one of the things the GNU autoconf ./configure script checks for
is a working GNU m4, so having the wrong version of m4 on your system and
using autoconf would be a hard thing to accomplish, me thinks, unless the
autoconf one is using is from a package that didnt check for the right m4
itself.

/dale


Mime
View raw message