apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Fogel <kfo...@galois.collab.net>
Subject Re: FreeBSD and gnu m4
Date Tue, 27 Feb 2001 18:09:13 GMT
Greg Stein <gstein@lyra.org> writes:
> I'd rather we find out what is wrong with BSD m4.

News flash: it's not just BSD m4 -- my Debian Linux box also cannot
build APR now, with exactly the same errors as Ben reported from BSD.

   galois$ m4 --version
   GNU m4 1.4
   galois$ 

I have not been following this issue closely enough to have an opinion
on whether Jim J's patch is the right thing or not.  However, if it
works, I think we should commit it now and *then* come up with a
better fix, rather than have a broken head.

I will try it, & if it works, commit with a comment indicating that
further review is desired.

-K



> On Tue, Feb 27, 2001 at 10:04:39AM -0800, rbb@covalent.net wrote:
> > 
> > Jim just posted a patch which should solve the problem without using
> > GNUm4.
> > 
> > Ryan
> > 
> > On 27 Feb 2001, Ben Collins-Sussman wrote:
> > 
> > >
> > > Sorry, I'm confused here; my FreeBSD 4.2 system has /usr/bin/m4 and
> > > /usr/local/bin/gm4.  Do I need to do some icky softlinking to make APR
> > > use gm4?  Or is there a better solution?
> > >
> > >
> > >
> > 
> > 
> > _______________________________________________________________________________
> > Ryan Bloom                        	rbb@apache.org
> > 406 29th St.
> > San Francisco, CA 94131
> > -------------------------------------------------------------------------------
> 
> -- 
> Greg Stein, http://www.lyra.org/

Mime
View raw message