apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Stein <gst...@lyra.org>
Subject Re: cvs commit: apr-util/buckets apr_brigade.c
Date Wed, 28 Feb 2001 22:20:50 GMT
On Wed, Feb 28, 2001 at 11:46:39AM -0500, Cliff Woolley wrote:
>...
> HUGE_STRING_LEN comes from apr_lib.h, not from within aprutil, and other
> parts of APR (and maybe Apache, too) are using it.  It ought to be
> namespace protected (APR_HUGE_STRING_LEN) (don't I remember past
> discussion about this?).

Yes, it should be namespace protected. However, it would be even better to
simply nuke the thing. Any users should have a better symbol than "this is a
big-ass string." That doesn't say a lot about the symbol's purpose/usage.

So the question becomes, "in what context is that symbol used? is there a
better name/semantic to use for 8192 in those contexts?"

> At that point, we could just
> 
> #define APR_BUCKET_BUFF_SIZE  APR_HUGE_STRING_LEN
> 
> But then, is APR_BUCKET_BUFF_SIZE still useful?  Its name is probably more
> meaningful.

Exactly -- we would continue to use the APR_BUCKET_BUFF_SIZE name for its
semantic content.

However, it should not be defined in terms of APR_HUGE_STRING_LEN. The
latter has no meaning. We want the bucket buffer(s) to be 8192 bytes. *That*
has some meaning.

Cheers,
-g

-- 
Greg Stein, http://www.lyra.org/

Mime
View raw message