apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wilfredo Sanchez <wsanc...@MIT.EDU>
Subject shtool invokes head but misses and invokes something else?
Date Thu, 08 Feb 2001 22:03:13 GMT
   I'm trying to start the port to Darwin, and whenever the apr build 
calls shtool, I get this wierd unhappy spewage:

Unknown option: 1
Usage: head [-options] <url>...
     -m <method>   use method for the request (default is 'HEAD')
     -f            make request even if head believes method is illegal
     -b <base>     Use the specified URL as base
     -t <timeout>  Set timeout value
     -i <time>     Set the If-Modified-Since header on the request
     -c <conttype> use this content-type for POST, PUT, CHECKIN
     -a            Use text mode for content I/O
     -p <proxyurl> use this as a proxy
     -P            don't load proxy settings from environment
     -H <header>   send this HTTP header (you can specify several)

     -u            Display method and URL before any response
     -U            Display request headers (implies -u)
     -s            Display response status code
     -S            Display response status chain
     -e            Display response headers
     -d            Do not display content
     -o <format>   Process HTML content in various ways

     -v            Show program version
     -h            Print this message

     -x            Extra debugging output

Apparently, shtool is invoking "head -1" which should be fine, because 
head *does* accept a -1 argument, but instead some other program with 
the above usage is being invoked and I can't figure out why this might 
be the case.  Anybody recognize that usage output?  Certainly looks 
Apache-ish, but I can't find it in APR.

	-Fred

Wilfredo Sánchez - wsanchez@apache.org
Apache Software Foundation

Mime
View raw message