apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From r..@covalent.net
Subject Re: apr_portable.h
Date Fri, 26 Jan 2001 14:23:18 GMT

Because the point of apr_portable is to provide the portability
functions.  It is named that, because the apr_get_os_foo and
apr_set_os_foo calls are used to make sure that APR can be used with
non-APR programs, and those have always been referred to as portability
functions.  This may be a bad name, but it is in use, and I would
personally prefer it stay, because all of my articles have called them
that, so people expect that function.


On Thu, 25 Jan 2001, Greg Stein wrote:

> Why is apr_portable.h full of OS-specific, *NON* -portable stuff?
> Shouldn't it be apr_os.h or something?
> Cheers,
> -g
> -- 
> Greg Stein, http://www.lyra.org/

Ryan Bloom                        	rbb@apache.org
406 29th St.
San Francisco, CA 94131

View raw message