apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Reid" <dr...@jetnet.co.uk>
Subject Re: apr_portable.h
Date Fri, 26 Jan 2001 18:29:03 GMT
The other way (and I'm not suggesting we'd want to do this) would be to
generate the file.  GLib does something similar.  Basically it means we'd
end up with a platform specific apr_private.h with no platform specific code
sections as the whole thing would be platform specific.  Whether this is
worth the effort I'm not sure though!

david
----- Original Message -----
From: <rbb@covalent.net>
To: "Greg Stein" <gstein@lyra.org>
Cc: <dev@apr.apache.org>
Sent: Friday, January 26, 2001 2:23 PM
Subject: Re: apr_portable.h


>
> Because the point of apr_portable is to provide the portability
> functions.  It is named that, because the apr_get_os_foo and
> apr_set_os_foo calls are used to make sure that APR can be used with
> non-APR programs, and those have always been referred to as portability
> functions.  This may be a bad name, but it is in use, and I would
> personally prefer it stay, because all of my articles have called them
> that, so people expect that function.
>
> Ryan
>
> On Thu, 25 Jan 2001, Greg Stein wrote:
>
> > Why is apr_portable.h full of OS-specific, *NON* -portable stuff?
> >
> > Shouldn't it be apr_os.h or something?
> >
> > Cheers,
> > -g
> >
> > --
> > Greg Stein, http://www.lyra.org/
> >
> >
>
>
>
____________________________________________________________________________
___
> Ryan Bloom                        rbb@apache.org
> 406 29th St.
> San Francisco, CA 94131
> --------------------------------------------------------------------------
-----
>
>



Mime
View raw message