apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: cvs commit: apr/file_io/unix filestat.c
Date Wed, 24 Jan 2001 22:29:23 GMT
That's odd - it works flawlessly for me.

The bug's gotta be in apr_stat, since I mod_autoindex looks at nothing
but the filename and creates the subrequest to parse each file entry.
Hmmm... could be the apr_lstat variety, better be sure we clear that
flag out.  I'm thinking that ->valid |= APR_FINFO_STAT should tell the
user we did an lstat() instead of a stat(), and leave the APR_LNK flag 
to tell them that it was (or wasn't) a link.

Maybe that's the bit that's fooling us all.

Bill

----- Original Message ----- 
From: "Jeff Trawick" <trawickj@bellsouth.net>
To: "William A. Rowe, Jr." <wrowe@rowe-clan.net>
Cc: <dev@apr.apache.org>
Sent: Wednesday, January 24, 2001 4:01 PM
Subject: Re: cvs commit: apr/file_io/unix filestat.c


> "William A. Rowe, Jr." <wrowe@rowe-clan.net> writes:
> 
> > > trawick     01/01/24 13:11:52
> > > 
> > >   Modified:    file_io/unix filestat.c
> > >   Log:
> > >   get filestat.c to compile again
> > 
> > and it rides again, I presume?  Thanks Jeff
> 
> autoindex is still failing for me; I'll play with it some more
> 
> -- 
> Jeff Trawick | trawickj@bellsouth.net | PGP public key at web site:
>        http://www.geocities.com/SiliconValley/Park/9289/
>              Born in Roswell... married an alien...
> 


Mime
View raw message