apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From r..@covalent.net
Subject Re: [PATCH] Buckets: add copy function, ap_bucket_split_any(), etc
Date Sat, 09 Dec 2000 16:50:03 GMT

> > location.  However, now we are talking about a different function, which
> > is a brigade split based on offset.  If that is what we are after, then
> > the name is incorrect.
> Hrm. True. If you have a pipe bucket and you ask to split at 1000, but the
> pipe contains 500, then you're actually splitting *past* the pipe and into
> the brigade.
> I'd be *quite* happy to rename it as "ap_brigade_split()".

Can't do that.  :-)  We already have ap_brigade_split.  I would call it
ap_brigade_split_offset or something like that.

> And to have it return the bucket pointer where the split occurs. (that isn't
> super clear...) Like so:
> brigade      split-head
>   \           \ 
>    B1 -> B2 -> B3 -> B4 -> B5 -> B6

I would make a small modification to this.  The returned object shouldn't
be a bucket list, it should be a brigade, just like the other
ap_brigade_split function that we already have.


Ryan Bloom                        	rbb@apache.org
406 29th St.
San Francisco, CA 94131

View raw message