apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cliff Woolley <cliffwool...@yahoo.com>
Subject Re: [PATCH] Buckets: add copy function, ap_bucket_split_any(), etc
Date Sat, 09 Dec 2000 18:23:15 GMT

--- rbb@covalent.net wrote:
> Can't do that.  :-)  We already have ap_brigade_split.  I would call it
> ap_brigade_split_offset or something like that.

Okay.  ap_brigade_split_offset() it is.  I think that's a more clear name anyway. 
But again, what about _copy_any()?  Should it be ap_brigade_copy()?

Also, I was never 100% decided about one aspect of the bucket copy API, which is the
return value... should the ap_bucket* be the actual return value, or should it be an
apr_status_t?  I ended up going with the apr_status_t return value to accomodate
APR_ENOTIMPL.  Do people agree with that decision?

On the other hand, it seems that ap_brigade_copy() ought to return an
ap_bucket_brigade* to match ap_brigade_split() and ap_brigade_split_offset().  Yes?


Do You Yahoo!?
Yahoo! Shopping - Thousands of Stores. Millions of Products.

View raw message