apr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Stein <gst...@lyra.org>
Subject Re: cvs commit: apr-util/build rules.mk.in
Date Sat, 02 Dec 2000 22:09:43 GMT
On Sat, Dec 02, 2000 at 02:00:40PM -0800, rbb@covalent.net wrote:
> On Sat, 2 Dec 2000, Greg Stein wrote:
> 
> > What platform are you trying to build on? And what is the problem you're
> > seeing?
> > 
> > All of my testing was on Linux, and it worked like a charm (before/after the
> > change below). So... I'm wondering what part isn't working for you?
> 
> I'm on Linux, and SUBDIRS was always NULL.  This is how Apache does it, so
> I tried just copying from Apache to apr-utils, and it solved my problem.

Dang. That is just wonky. I've got RedHat 6.1 installed. The relevant
packages are:

  make-3.77-6
  bash-1.14.7-16
  autoconf-2.13-5
  libtool-1.3.4-3

What do you have?

I've got no problem with the change, but I'd like to understand what is
going wrong. Why is SUBDIRS always null?

Hmm. I wonder if it does the substitution for SUBDIRS when it reads the rule
(via the include) rather than when the rule is invoked. In all of the
makefiles, SUBDIRS is set after the include. Could that be the problem
you're seeing?

Cheers,
-g

-- 
Greg Stein, http://www.lyra.org/

Mime
View raw message