apr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wr...@apache.org
Subject svn commit: r20015 - /dev/apr/RELEASE-NOTES-1.6
Date Tue, 13 Jun 2017 04:16:49 GMT
Author: wrowe
Date: Tue Jun 13 04:16:49 2017
New Revision: 20015

Log:
Switch to declaratives, reference new expat home

Modified:
    dev/apr/RELEASE-NOTES-1.6

Modified: dev/apr/RELEASE-NOTES-1.6
==============================================================================
--- dev/apr/RELEASE-NOTES-1.6 (original)
+++ dev/apr/RELEASE-NOTES-1.6 Tue Jun 13 04:16:49 2017
@@ -1,7 +1,7 @@
 Please see the CHANGES files for details of programming changes.
-New APIs may have been introduced, but this release should be
-fully compatible at both source and binary level with programs
-developed using earlier APR-1.x/APR-UTIL-1.x versions.
+Although APIs have been been introduced, this release is fully
+compatible at both source and binary level with programs developed
+using earlier APR-1.x/APR-UTIL-1.x versions.
 
 Externally visible changes that affect build and/or installation are:
 
@@ -17,21 +17,29 @@ There are a number of updates to how APR
 dependencies:
 
 - XML:
-  Expat is no longer bundled, and has instead become a dependency.
-  You will need expat installed on your system to use APR-UTIL
-  (expat is installed as standard on most systems).  If you are
-  building APR-UTIL, you might (depending on your system's packaging
-  policies) need to install an additional expat-dev or expat-devel package.
+
+  - Expat sources are no longer bundled, this is now an external
+    dependency. You must install expat on your system to use APR-UTIL
+    (expat is installed as standard on most systems).  If you are
+    building APR-UTIL, you may need to obtain expat 2.2 or later
+    from https://libexpat.github.io/ or depending on your system's
+    packaging policies, install their expat-dev or expat-devel package.
+    Note that 2.2 addressed some security vulnerabilities of earlier
+    libexpat project releases.
 
 - CRYPTO:
+
   - OpenSSL support is updated to support OpenSSL version 1.1.
+
   - Apple's CommonCrypto is supported for Mac and IOS platforms.
 
 - DATABASE:
+
   - MySQL support has been updated as advised by the MySQL developers.
     MySQL versions older than 5.5 should not be used.  Or if you
     do use an old MySQL version, you will need to hack the build
     to use the thread-safe libmysqlclient_r version of the library.
+
   - FreeTDS partial and incomplete support has been dropped.
     Users of MSSQL and SYBASE databases are recommended to use
     the ODBC driver instead.



Mime
View raw message