apr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rj...@apache.org
Subject svn commit: r1021428 - /apr/apr-util/branches/0.9.x/build/apu-conf.m4
Date Mon, 11 Oct 2010 17:03:23 GMT
Author: rjung
Date: Mon Oct 11 17:03:22 2010
New Revision: 1021428

URL: http://svn.apache.org/viewvc?rev=1021428&view=rev
Log:
Fix link path for bundled expat used by apr-util.

Linking was broken after moving libexpat from
xml/expat/lib to xml/expat, which is the default
location for the original expat library.

The breakage only occured when using bundled expat
without explicitely giving "--with-expat=builtin" on
BeOS, Darwin, AIX and CYGWIN. Those platforms
link explicitely against libexpat. The other *nix
platforms just leave the expat symbols unresolved
and the app using apr-util needs to load libexpat
during runtime linking.

Modified:
    apr/apr-util/branches/0.9.x/build/apu-conf.m4

Modified: apr/apr-util/branches/0.9.x/build/apu-conf.m4
URL: http://svn.apache.org/viewvc/apr/apr-util/branches/0.9.x/build/apu-conf.m4?rev=1021428&r1=1021427&r2=1021428&view=diff
==============================================================================
--- apr/apr-util/branches/0.9.x/build/apu-conf.m4 (original)
+++ apr/apr-util/branches/0.9.x/build/apu-conf.m4 Mon Oct 11 17:03:22 2010
@@ -178,7 +178,7 @@ if test "$expat_include_dir" = "xml/expa
   expat_include_dir=$top_builddir/$bundled_subdir/lib
   expat_ldflags="-L$top_builddir/$bundled_subdir/lib"
   expat_libs="-lexpat"
-  expat_libtool=$top_builddir/$bundled_subdir/lib/libexpat.la
+  expat_libtool=$top_builddir/$bundled_subdir/libexpat.la
   APR_XML_SUBDIRS="`echo $bundled_subdir | sed -e 's%xml/%%'`"
   APR_ADDTO(APRUTIL_EXPORT_LIBS, [$expat_libtool])
 else



Mime
View raw message