apr-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From field...@apache.org
Subject cvs commit: apr/build buildcheck.sh
Date Sat, 24 Mar 2001 06:48:04 GMT
fielding    01/03/23 22:48:04

  Added:       build    buildcheck.sh
  Log:
  This shell script checks the builder's setup for the right versions
  of the build tools (autoconf and libtool) needed to build APR on unix.
  
  Moved from httpd-2.0/build/buildcheck.sh
  
  Submitted by:	Sascha Schumann
  
  Revision  Changes    Path
  1.1                  apr/build/buildcheck.sh
  
  Index: buildcheck.sh
  ===================================================================
  #! /bin/sh
  
  echo "buildconf: checking installation..."
  
  # autoconf 2.13 or newer
  ac_version=`autoconf --version 2>/dev/null|head -1|sed -e 's/^[^0-9]*//' -e 's/[a-z]*
*$//'`
  if test -z "$ac_version"; then
  echo "buildconf: autoconf not found."
  echo "           You need autoconf version 2.13 or newer installed"
  echo "           to build Apache from CVS."
  exit 1
  fi
  IFS=.; set $ac_version; IFS=' '
  if test "$1" = "2" -a "$2" -lt "13" || test "$1" -lt "2"; then
  echo "buildconf: autoconf version $ac_version found."
  echo "           You need autoconf version 2.13 or newer installed"
  echo "           to build Apache from CVS."
  exit 1
  else
  echo "buildconf: autoconf version $ac_version (ok)"
  fi
  
  # libtool 1.3.3 or newer
  lt_pversion=`libtool --version 2>/dev/null|sed -e 's/^[^0-9]*//' -e 's/[- ].*//'`
  if test "$lt_pversion" = ""; then
  echo "buildconf: libtool not found."
  echo "           You need libtool version 1.3 or newer installed"
  echo "           to build Apache from CVS."
  exit 1
  fi
  lt_version=`echo $lt_pversion|sed -e 's/\([a-z]*\)$/.\1/'`
  IFS=.; set $lt_version; IFS=' '
  if test "$1" -gt "1" || test "$2" -gt "3" || test "$2" = "3" -a "$3" -ge "3"
  then
  echo "buildconf: libtool version $lt_pversion (ok)"
  else
  echo "buildconf: libtool version $lt_pversion found."
  echo "           You need libtool version 1.3.3 or newer installed"
  echo "           to build Apache from CVS."
  exit 1
  fi
  
  exit 0
  
  
  

Mime
View raw message