apr-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 59927] apr-util needs some tweaks for mysql 5.7 where is no libmysqlclient_r
Date Mon, 10 Oct 2016 10:52:44 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=59927

--- Comment #2 from Norvald H. Ryeng <norvald.ryeng@oracle.com> ---
Hi! I've been working on the limysqlclient_r -> libmysqlclient transition at
Oracle.

There is no reason to prefer libmysqlclient_r over libmysqlclient. In all
current releases, libmysqlclient is the preferred library. The last MySQL
version to be shipped with a separate libmysqlclient_r library was MySQL 5.1,
which was EOLed on December 31, 2013. We kept libmysqlclient_r as a
compatibility symlink in MySQL 5.5 and 5.6, and removed it in 5.7. In MySQL 8.0
(currently in development), the --libs_r option to mysql-config is also gone.

It doesn't hurt to pick libmysqlclient_r over libmysqlclient, as suggested in
the previous comment, but I don't think it's necessary to add the complexity.

For more info:

http://mysqlserverteam.com/the-client-library-part-3-building-mysql-client-applications/
http://mysqlserverteam.com/deprecating-the-mysql_config-libs_r-option/
https://www.mysql.com/support/eol-notice.html

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@apr.apache.org
For additional commands, e-mail: bugs-help@apr.apache.org


Mime
View raw message