apr-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 59698] New: "The system cannot find the path specified." when building apr using nmake on Windows
Date Mon, 13 Jun 2016 23:14:59 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=59698

            Bug ID: 59698
           Summary: "The system cannot find the path specified." when
                    building apr using nmake on Windows
           Product: APR
           Version: HEAD
          Hardware: PC
            Status: NEW
          Severity: normal
          Priority: P2
         Component: APR
          Assignee: bugs@apr.apache.org
          Reporter: luke1410@gmx.de

running nmake -f Makefile.win (OS: Win10 64-bit, VS 2015 CE Update 2) raises
the following error:
"The system cannot find the path specified."

and incorrectly sets the ARCH to Win32 Release instead of x64 Release.

As far as I can tell the issue is in Makefile.win ln 49 where $(SystemRoot) is
specified, while according to the nmake documentation, environment variables
are converted to uppercase letters. [1]

Replacing $(SystemRoot) with $(SYSTEMROOT) resolves the issue for me here.

[1] https://msdn.microsoft.com/en-us/library/99at5bh3.aspx

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@apr.apache.org
For additional commands, e-mail: bugs-help@apr.apache.org


Mime
View raw message