apr-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 56095] New: ProxyPassMatch rules with "?:" breaks since APR-UTIL v 1.5.2
Date Fri, 31 Jan 2014 13:19:00 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=56095

            Bug ID: 56095
           Summary: ProxyPassMatch rules with "?:" breaks since APR-UTIL v
                    1.5.2
           Product: APR
           Version: 1.5.3
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: APR-util
          Assignee: bugs@apr.apache.org
          Reporter: andre.wendel@bmw.de

The following ProxyPassMatch-Rules 

ProxyPassMatch ^(.*\.jsp(?:;.*)?)$ balancer://appcluster$1

break, since APR-UTIL 1.5.2 with the following failure, 

"ProxyPass Unable to parse URL".

In 1.5.1 they worked without any problems.

The rule runs also without any problem if you put a "/" in front of the rule
i.e. 

ProxyPassMatch ^/(.*\.jsp(?:;.*)?)$ balancer://appcluster/$1

I have done some more investigation here and found out that the problem is not
the "/" inside the ProxyPassMatch, the problem is the perl regex "?:".

I have tried multiple configurations of apache and the problem appears if an
APR-UTIL > 1.5.1 is used!

Current compile tests runs, without a problem:

HTTP 2.4.6
APR 1.50
APR-UTIL 1.5.1
PCRE 8.34

The following configuration breaks:
HTTP 2.4.6
APR 1.50
APR-UTIL 1.5.2
PCRE 8.34

See also https://issues.apache.org/bugzilla/show_bug.cgi?id=56074

Best regards,
André

-- 
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@apr.apache.org
For additional commands, e-mail: bugs-help@apr.apache.org


Mime
View raw message